<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://cleveland.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="kolby parker, ronald wells sr., florida man, man cuts off ears, human ears, grandfather ears, murder, deland, central florida" />
<meta name="keywords" content="kolby parker, ronald wells sr., florida man, man cuts off ears, human ears, grandfather ears, murder, deland, central florida" />
<meta property="fb:pages" content="256053637756622" />
<title>Man Confesses To Killing Grandfather, Pulls Human Ears From Pocket During Questioning &#8211; CBS Cleveland</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Cleveland &raquo; Feed" href="https://cleveland.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://cleveland.cbslocal.com/_static/??-eJytUEkOwjAM/BDBRKgSHBBvyWJKVMeOsqjfJ7RceoJKnGyPPaMZw5yUE67IFeoTIxZwtigSZwgCO2r+DZUCD5GK+djbA/xEwmjRr9yUkcT47+REbQxcIIpv1Dc2o5kCj4pxXqU2yH5B83HU637ycqCiYTNiXmQ2iOqppyppx49WjRYtm0CKAk//d4XUJ65L3nu86eFy1eeTHvQLjM6+EQ==' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://cleveland.cbslocal.com/_static/??-eJyNy0sKgDAMANELWWOQgi7Es9QYVEg/kIh4e+0FxO3wBq7iKCfjZGA7R1agRZ1kCgJqt3BLqg18sSORnGtNqlDCxs44Fgn2460LyxuTadVznNAPI/YdenwAIdA5Fg==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://cleveland.cbslocal.com/_static/??-eJydUltOxDAMvBBpVKAIPhBnSROrG9aJo8TdqrfH2bKsoOIR/vya8YwTvSRlKTJE1nyAAEXbsSgka1AnnCcfiw7kZpTOeUAFE80EWdsilTXBfSfRjf6JyEeLs6slwSzegWIICQ1DaQQnk/kPmK/Ky4EyW7qwXNOG9RBGcBv+HCr0hZU1bJCmRhviwlsEdboe71PfCbUeBXiULWM2edWFV4Qu+NjuXi4+AX9cv8Y7kjCrC+wVOBnZ/NQNOwqmpBIViTY9zVr2fyiYfKzU27wlpPyPF/6Nl06Ql+x5L/kb55XiPa+Ql/DcP/TD3W0/DI9vrIc0Kg==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://cleveland.cbslocal.com/_static/??-eJy1UEEOwjAM+xBdtaEhcUC8pXTZaEnTsqRD+z1l4sBuA4mTFcd2rOhHUjaSAImWKwRgbS+sMFqD2pHF3BXKs04R594hVsFR5Xmntxr9JkfCPDhiHWKXsWxMt5gLqKn5TFhF3zOM8xs2iVRww2gEfuq0CFQwZAYYX9ErQpV7N4npq+f0may4SPyPQoBlIuGSew6n+lC3+6Zu26N/ArC3ujg='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://cleveland.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILWwSTBwQ39KlUZcqbSeSst+nQrvswm6W/WzDtnZYslE2sIUSKeCsnRR0ApxRqm9WVHB+IeUP9YlzH/UC/4qND1JmJ6fk4eJtjEKnnVVq4KyQiq/Sko19IPtN7LJNvNJzuD2G63ifpjF+AQq7VNI='></script>
<link rel="https://api.w.org/" href="https://cleveland.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cleveland.cbslocal.com/wp-json/wp/v2/posts/408514" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cleveland.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cleveland.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://cbsloc.al/3eLTOK8' />
<link rel="alternate" type="application/json+oembed" href="https://cleveland.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcleveland.cbslocal.com%2F2021%2F03%2F16%2Fkolby-parker-florida-man-confesses-murder-ronald-wells-pulls-ears-during-questioning%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cleveland.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcleveland.cbslocal.com%2F2021%2F03%2F16%2Fkolby-parker-florida-man-confesses-murder-ronald-wells-pulls-ears-during-questioning%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="Man Confesses To Killing Grandfather, Pulls Human Ears From Pocket During Questioning" /><meta property="og:image" content="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/03/Kolby-Parker-mug.jpg?w=1500" /><meta property="og:image:secure_url" content="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/03/Kolby-Parker-mug.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="844" /><meta property="og:description" content="A Florida man is charged with murdering his 77-year-old grandfather and cutting the elderly man’s ears off with a knife." /><meta property="og:type" content="article" /><meta property="og:url" content="https://cleveland.cbslocal.com/2021/03/16/kolby-parker-florida-man-confesses-murder-ronald-wells-pulls-ears-during-questioning/" /><meta property="article:published_time" content="2021-03-16T13:40:52+00:00" /><meta property="article:suggested-social-copy" content="A Florida man is charged with murdering his 77-year-old grandfather and cutting the elderly man’s ears off with a knife." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Around the Nation" /><meta property="article:publisher" content="https://www.facebook.com/CBSLocal" /><meta property="article:author" content="https://www.facebook.com/CBSLocal" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/03/Kolby-Parker-mug.jpg?w=1500"><meta name="twitter:title" content="Man Confesses To Killing Grandfather, Pulls Human Ears From Pocket During Questioning"/><meta name="twitter:description" content="A Florida man is charged with murdering his 77-year-old grandfather and cutting the elderly man’s ears off with a knife."/><meta name="twitter:site" content="CBSLocal"/>
<link rel="canonical" href="https://miami.cbslocal.com/2021/03/15/florida-man-confesses-grandfather-murder-human-ears/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://cleveland.cbslocal.com/2021/03/16/kolby-parker-florida-man-confesses-murder-ronald-wells-pulls-ears-during-questioning/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/cleveland.cbslocal.com","url":"https:\/\/cleveland.cbslocal.com","name":"CBS Cleveland","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/cleveland.cbslocal.com\/wp-content\/uploads\/sites\/19705111\/2018\/07\/2_cbs_cleveland.png?w=245"}},"url":"https:\/\/cleveland.cbslocal.com\/2021\/03\/16\/kolby-parker-florida-man-confesses-murder-ronald-wells-pulls-ears-during-questioning\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/cleveland.cbslocal.com\/2021\/03\/16\/kolby-parker-florida-man-confesses-murder-ronald-wells-pulls-ears-during-questioning\/"},"headline":"Man Confesses To Killing Grandfather, Pulls Human Ears From Pocket During Questioning","description":"A Florida man is charged with murdering his 77-year-old grandfather and cutting the elderly man\u2019s ears off with a knife.","image":"https:\/\/cleveland.cbslocal.com\/wp-content\/uploads\/sites\/19705111\/2021\/03\/Kolby-Parker-mug.jpg?w=1500","keywords":["Around the Nation","Man Confesses To Killing Grandfather, Pulls Human Ears From Pocket During Questioning"],"datePublished":"2021-03-16T13:40:52+00:00","dateModified":"2021-03-16T13:40:52+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.CLEVELAND","default",["manconfessestokillinggrandfatherpullshumanearsfrompocketduringquestioning","post","article","aroundthenation","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
  line-height: 100%;
}

.postid-402048 .partner-container, .postid-401365 .partner-container {
	display: none;
}
		</style>
		<!-- WP Header - End -->

	<meta name="description" content="A Florida man is charged with murdering his 77-year-old grandfather and cutting the elderly man’s ears off with a knife." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-408514 single-format-standard desktop-display-type  and-temp-wide w-breaking-news"><div id="wrapper" class="body-wrapper">

<div id="breaking-news"><div class="wrapper"></div></div><div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://cleveland.cbslocal.com" id="header-logo"><img src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2018/07/2_cbs_cleveland.png?w=245" alt="CBS Cleveland" /></a>
	
	<nav id="navigation-main" data-item-count="6"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link"><a href="http://cleveland.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://cleveland.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://cleveland.cbslocal.com/category/sports/" title="Latest Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest Sports</strong></div></a><a href="http://www.sportsline.com/" title="ODDS" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">ODDS</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a><a href="http://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cleveland.cbslocal.com/2021/03/16/spring-training-report-shohei-ohtani-jacob-degrom-fan-attendence/" title="Spring Training Report: Has Shohei Ohtani Finally Returned To Form?" class="cbs-thumbnail-link item-1615907382" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/03/shohei-ohtani-angels-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Spring Training Report: Has Shohei Ohtani Finally Returned To Form?</strong><em class="description">Spring Training Report looks at a seemingly healthy Shohei Ohtani, Jacob deGrom&#039;s increasing velocity and teams&#039; plans to have fans in seats.</em></div></a><a href="https://cleveland.cbslocal.com/2021/03/15/2021-ncaa-tournament-television-schedule-cbs-turner/" title="March Madness 2021: TV Schedule, Full Bracket, How To Watch" class="cbs-thumbnail-link item-1615810852" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/03/GettyImages-1231633733.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">March Madness 2021: TV Schedule, Full Bracket, How To Watch</strong><em class="description">The schedule for the first three days of NCAA Tournament is set beginning with First Four play on Thursday, March 18.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link"><a href="http://cleveland.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://cleveland.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://cleveland.cbslocal.com/category/best-of/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cleveland.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2020/05/nonstickpans.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://cleveland.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2020/05/homemadepretzel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a><a href="https://cleveland.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="cbs-thumbnail-link item-1589569648" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2020/05/chowhound111.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 Vodka Sauce Recipes To Try This Week</strong><em class="description">And would you miss it if it wasn&#039;t there?</em></div></a><a href="https://cleveland.cbslocal.com/2020/05/15/best-make-ahead-freezer-meals/" title="Try These Make-Ahead Freezer Meals Perfect For Weeknights" class="cbs-thumbnail-link item-1589569416" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2020/05/freezerfood.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Try These Make-Ahead Freezer Meals Perfect For Weeknights</strong><em class="description">Set yourself up for easy weeknight dinners no matter what!</em></div></a><a href="https://cleveland.cbslocal.com/2020/05/13/the-most-searched-recipe-in-every-state-during-quarantine-coronavirus/" title="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" class="cbs-thumbnail-link item-1589398031" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2020/05/QuarantineRecipesFeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine</strong><em class="description">Find the most popular eats for your home state and across the country during the coronavirus quarantine.</em></div></a><a href="https://cleveland.cbslocal.com/2020/05/13/how-to-make-homemade-bagels-quarantine/" title="Quarantine Recipes: How To Make Homemade Bagels" class="cbs-thumbnail-link item-1589397541" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2020/05/bagelfeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Recipes: How To Make Homemade Bagels</strong><em class="description">See how to make your own homemade bagels while stuck inside during quarantine.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://cleveland.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cleveland.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2019/08/GettyImages-466663843.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://cleveland.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://cleveland.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2019/04/igworthy.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://cleveland.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2019/04/187774436.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a><a href="https://cleveland.cbslocal.com/2019/04/04/final-four-guide-5-restaurants-near-u-s-bank-stadium/" title="Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium" class="cbs-thumbnail-link item-1554410992" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2019/04/107277389-e1538670804895.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: 5 Restaurants To Try Near U.S. Bank Stadium</strong><em class="description">In Minneapolis for the Final Four and want to try the restaurants where Minneapolitans love to eat? Look no further. Below are some of the most beloved spots in the City of Lakes within walking distance, or a short Lyft ride, from U.S. Bank Stadium.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://cleveland.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519662648" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://cleveland.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Man Confesses To Killing Grandfather, Pulls Human Ears From Pocket During Questioning</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">March 16, 2021 at 1:40 pm</time></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5397893","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5"},"comscore":{"clientId":"3000023","c3":"Cleveland.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/cbs.cleveland&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/3eLTOK8","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>LAKE COUNTY, Fla. (CBSMiami) &ndash;</strong> A Florida man is charged with murdering his 77-year-old grandfather and cutting the elderly man&rsquo;s ears off with a knife. Police say the suspect, Kolby Parker, even pulled the ears of the victim, identified as Ronald Wells Sr., out of his pockets when questioned.</p>
<p>According to <a href="https://cbs12.com/news/local/florida-man-admits-to-killing-grandfather-cutting-his-ears-off" target="_blank" rel="nofollow">CBS affiliate WPEC</a>, the Lake County Sheriff&#8217;s Office was called to a home in DeLand in Central Florida on Saturday night for reports of a man who said he was attacked by his grandfather.&nbsp;Parker, 30, told deputies he and his grandfather were smoking marijuana when there was a confrontation. Parker claims he was only acting in self-defense when the older man attacked him with a knife. He told deputies he managed to get the knife away and used it on Wells, who was found dead on the front porch with multiple stab wounds.</p>
<p>While he was being questioned by police, Parker allegedly pulled two human ears from his pant pockets, which were later discovered to be those of his grandfather, according to the police report.</p>
<p>Deputies said Parker became violent toward them, but he was eventually subdued and taken into custody.</p>
<p>Investigators say Parker confessed to hitting his grandfather multiple times in the head with a baseball bat and then stabbed him with a butcher knife numerous times. He also admitted to cutting his grandfather&#8217;s ears off and stated that he wanted his grandfather to be with his dead grandmother.</p>
<p>Parker is charged with second-degree murder, battery on a law enforcement officer, and resisting with violence.</p>
<p>He is being held with no bond.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3eLTOK8"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3eLTOK8"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3eLTOK8"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSLocal" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="http://twitter.com/#!/CBSLocal" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://cleveland.cbslocal.com/2021/02/22/the-neighborhood-beth-behrs-tichina-arnold-cbs/" title="Beth Behrs And Tichina Arnold On What &#039;The Neighborhood&#039; Hopes To Achieve: &#039;Strike Conversations In Places That You Normally Never Would&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/117225_0418b.jpg?resize=55%2C55&#038;ssl=1" alt="Beth Behrs And Tichina Arnold On What &#039;The Neighborhood&#039; Hopes To Achieve: &#039;Strike Conversations In Places That You Normally Never Would&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/22/the-neighborhood-beth-behrs-tichina-arnold-cbs/" title="Beth Behrs And Tichina Arnold On What &#039;The Neighborhood&#039; Hopes To Achieve: &#039;Strike Conversations In Places That You Normally Never Would&#039;" class="bump-view" data-bump-view="tp">Beth Behrs And Tichina Arnold On What &#039;The Neighborhood&#039; Hopes To Achieve: &#039;Strike Conversations In Places That You Normally Never Would&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2021/02/18/clarice-michael-cudlitz-paul-krendler-season-1/" title="Michael Cudlitz On Paul Krendler&#039;s Relationship With &#039;Clarice&#039;: &#039;He Does Not Care For Her, She&#039;s Dangerous&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/117192_0509b.jpg?resize=55%2C55&#038;ssl=1" alt="Michael Cudlitz On Paul Krendler&#039;s Relationship With &#039;Clarice&#039;: &#039;He Does Not Care For Her, She&#039;s Dangerous&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/18/clarice-michael-cudlitz-paul-krendler-season-1/" title="Michael Cudlitz On Paul Krendler&#039;s Relationship With &#039;Clarice&#039;: &#039;He Does Not Care For Her, She&#039;s Dangerous&#039;" class="bump-view" data-bump-view="tp">Michael Cudlitz On Paul Krendler&#039;s Relationship With &#039;Clarice&#039;: &#039;He Does Not Care For Her, She&#039;s Dangerous&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2021/02/24/gonzaga-creighton-loyola-chicago-san-diego-state-ncaa-basketball-preview/" title="Gonzaga, One Of Five Ranked Teams On Five Consecutive Nights, &#039;Just Has So Many Different Answers,&#039; Says CBS Sports&#039;s Jon Rothstein" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/jalen-suggs-andrew-nembhard-drew-timme-1.jpg?resize=55%2C55&#038;ssl=1" alt="Gonzaga, One Of Five Ranked Teams On Five Consecutive Nights, &#039;Just Has So Many Different Answers,&#039; Says CBS Sports&#039;s Jon Rothstein" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/24/gonzaga-creighton-loyola-chicago-san-diego-state-ncaa-basketball-preview/" title="Gonzaga, One Of Five Ranked Teams On Five Consecutive Nights, &#039;Just Has So Many Different Answers,&#039; Says CBS Sports&#039;s Jon Rothstein" class="bump-view" data-bump-view="tp">Gonzaga, One Of Five Ranked Teams On Five Consecutive Nights, &#039;Just Has So Many Different Answers,&#039; Says CBS Sports&#039;s Jon Rothstein</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2021/02/19/byu-loyola-marymount-cbs-sports-network-analytics-broadcast/" title="CBS Sports Network Going &#039;Beyond The Box Score&#039; To Educate Fans On Analytics And How They&#039;re Used For Saturday&#039;s BYU-Loyola Marymount Matchup" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/BTBS.jpg?resize=55%2C55&#038;ssl=1" alt="CBS Sports Network Going &#039;Beyond The Box Score&#039; To Educate Fans On Analytics And How They&#039;re Used For Saturday&#039;s BYU-Loyola Marymount Matchup" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/19/byu-loyola-marymount-cbs-sports-network-analytics-broadcast/" title="CBS Sports Network Going &#039;Beyond The Box Score&#039; To Educate Fans On Analytics And How They&#039;re Used For Saturday&#039;s BYU-Loyola Marymount Matchup" class="bump-view" data-bump-view="tp">CBS Sports Network Going &#039;Beyond The Box Score&#039; To Educate Fans On Analytics And How They&#039;re Used For Saturday&#039;s BYU-Loyola Marymount Matchup</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2020/12/11/taunton-man-late-father-buys-first-beer-21st-birthday-surprise/" title="&#039;Like He Was There&#039;: Late Father Buys Son First Beer On 21st Birthday" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2020/12/beer.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;Like He Was There&#039;: Late Father Buys Son First Beer On 21st Birthday" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2020/12/11/taunton-man-late-father-buys-first-beer-21st-birthday-surprise/" title="&#039;Like He Was There&#039;: Late Father Buys Son First Beer On 21st Birthday" class="bump-view" data-bump-view="tp">&#039;Like He Was There&#039;: Late Father Buys Son First Beer On 21st Birthday</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2021/02/26/deja-mcclendon-athletes-unlimited-volleyball-interview/" title="Deja McClendon On Athletes Unlimited Volleyball: &#039;We Really Want To See This Grow&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/athletes-unlimited-volleyball-e1614346103344.jpg?resize=55%2C55&#038;ssl=1" alt="Deja McClendon On Athletes Unlimited Volleyball: &#039;We Really Want To See This Grow&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/26/deja-mcclendon-athletes-unlimited-volleyball-interview/" title="Deja McClendon On Athletes Unlimited Volleyball: &#039;We Really Want To See This Grow&#039;" class="bump-view" data-bump-view="tp">Deja McClendon On Athletes Unlimited Volleyball: &#039;We Really Want To See This Grow&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2021/02/26/texas-texas-tech-pete-gillen-greg-brown/" title="#14 Texas Looks For Revenge Against #18 Texas Tech Saturday On CBS, Analyst Pete Gillen Says Longhorns&#039; Greg Brown Is Player To Watch" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/GettyImages-1229880691.jpg?resize=55%2C55&#038;ssl=1" alt="#14 Texas Looks For Revenge Against #18 Texas Tech Saturday On CBS, Analyst Pete Gillen Says Longhorns&#039; Greg Brown Is Player To Watch" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/26/texas-texas-tech-pete-gillen-greg-brown/" title="#14 Texas Looks For Revenge Against #18 Texas Tech Saturday On CBS, Analyst Pete Gillen Says Longhorns&#039; Greg Brown Is Player To Watch" class="bump-view" data-bump-view="tp">#14 Texas Looks For Revenge Against #18 Texas Tech Saturday On CBS, Analyst Pete Gillen Says Longhorns&#039; Greg Brown Is Player To Watch</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2021/02/11/march-madness-bracket-preview-cbs-february-13/" title="NCAA March Madness Bracket Preview Show Airing On CBS Saturday, February 13" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/GettyImages-1131685697.jpg?resize=55%2C55&#038;ssl=1" alt="NCAA March Madness Bracket Preview Show Airing On CBS Saturday, February 13" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/11/march-madness-bracket-preview-cbs-february-13/" title="NCAA March Madness Bracket Preview Show Airing On CBS Saturday, February 13" class="bump-view" data-bump-view="tp">NCAA March Madness Bracket Preview Show Airing On CBS Saturday, February 13</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2021/02/22/floribama-shore-cast-mtv-interview/" title="&#039;We Are Who People Really Are On The Weekends&#039;: The Floribama Shore Cast Previews Season 4 On MTV" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/GettyImages-976814268-e1614014350956.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;We Are Who People Really Are On The Weekends&#039;: The Floribama Shore Cast Previews Season 4 On MTV" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/22/floribama-shore-cast-mtv-interview/" title="&#039;We Are Who People Really Are On The Weekends&#039;: The Floribama Shore Cast Previews Season 4 On MTV" class="bump-view" data-bump-view="tp">&#039;We Are Who People Really Are On The Weekends&#039;: The Floribama Shore Cast Previews Season 4 On MTV</a>
							</div>
													</li>
										<li>
						<a href="https://cleveland.cbslocal.com/2021/02/19/michigan-ohio-state-cbs-bill-raftery/" title="#3 Michigan Takes On #4 Ohio State Sunday: CBS&#039; Bill Raftery Says Key Will Be &#039;Can Buckeyes Contain Hunter Dickinson&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2021/02/GettyImages-1297514926.jpg?resize=55%2C55&#038;ssl=1" alt="#3 Michigan Takes On #4 Ohio State Sunday: CBS&#039; Bill Raftery Says Key Will Be &#039;Can Buckeyes Contain Hunter Dickinson&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cleveland.cbslocal.com/2021/02/19/michigan-ohio-state-cbs-bill-raftery/" title="#3 Michigan Takes On #4 Ohio State Sunday: CBS&#039; Bill Raftery Says Key Will Be &#039;Can Buckeyes Contain Hunter Dickinson&#039;" class="bump-view" data-bump-view="tp">#3 Michigan Takes On #4 Ohio State Sunday: CBS&#039; Bill Raftery Says Key Will Be &#039;Can Buckeyes Contain Hunter Dickinson&#039;</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://cleveland.cbslocal.com" class="logo"><img src="https://cleveland.cbslocal.com/wp-content/uploads/sites/19705111/2017/10/cleveland.png" alt="CBS Cleveland" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSLocal" class="facebook" target="_blank">Facebook</a><a href="http://twitter.com/#!/CBSLocal" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://cleveland.cbslocal.com/category/sports/" title="Latest Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest Sports</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="http://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a><a href="http://www.cbssports.com/nhl/" title="NHL" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">NHL</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://cleveland.cbslocal.com/about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="http://cleveland.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="http://cleveland.cbslocal.com/about-us/contact-us/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://cleveland.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="http://cleveland.cbslocal.com/category/only-cbs/" title="Travel" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://cleveland.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://cleveland.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://cleveland.cbslocal.com" class="logo"><img src="https://cleveland.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Cleveland" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=cleveland.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-62021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62021"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-62020" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62020"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-402285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-402285"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-402286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-402286"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-258451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-258451"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://cleveland.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1589130151g' type='text/css' media='all' />
<script type='text/javascript' src='https://cleveland.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1615321560g'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202111.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.5.2',blog:'162245981',post:'408514',tz:'-4',srv:'cleveland.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162245981', '408514' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>